logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Daniel Comp  
#1 Posted : Friday, August 4, 2017 5:51:11 AM(UTC)
Daniel Comp

Rank: Advanced Member

Groups: Registered
Joined: 12/20/2016(UTC)
Posts: 56
United States
Location: Hood River

I've installed and configured (correctly I believe) version 3.5 and found missing product links. I looked in the product list template, and also upgraded to 3.6, and still can't figure out what's up.

missing link path

Missing link in cart as well

Does anybody know where Dave has gone to?

leedavi  
#2 Posted : Friday, August 4, 2017 7:18:30 AM(UTC)
leedavi

Rank: Administration

Groups: Registered, Administrators
Joined: 11/6/2016(UTC)
Posts: 325
United Kingdom
Location: France

Was thanked: 28 time(s) in 28 post(s)
Hi Daniel, I'm still around, but on semi-hoiday ATM.

This is strange, not seen it before.

What version of DNN are you using?
Have you turned on Friendly urls?
Have you loaded Open URL rewriter?

Have you tried putitng a SEO Name in the product? (It should default back to the product name, but try this anyway.)
Daniel Comp  
#3 Posted : Friday, August 4, 2017 4:32:41 PM(UTC)
Daniel Comp

Rank: Advanced Member

Groups: Registered
Joined: 12/20/2016(UTC)
Posts: 56
United States
Location: Hood River

Good for you on the vacation. Thanks for filling my voids!

I've got DNN V 08.00.04 running with OpenURL_rewriter V 1.4.2
I tried selecting FRIENDLY URLS both on and off.
I've added and changed the SEO Name on both products

I have another installation that works fine with (as near as I can tell) an identical setup.

I'll delete both the URL_rewriter and the store and start over with the setup. maybe I'm missing something or the sequence was wrong.

Enjoy your time off!
Daniel Comp  
#4 Posted : Friday, August 4, 2017 5:03:37 PM(UTC)
Daniel Comp

Rank: Advanced Member

Groups: Registered
Joined: 12/20/2016(UTC)
Posts: 56
United States
Location: Hood River

I removed the OpenURL_Rewriter and then had to fix the WebConfig file. It had 'HumanFriendly' and not 'Advanced'

<friendlyUrl defaultProvider="DNNFriendlyUrl">
<providers>
<clear />
<add name="DNNFriendlyUrl" type="DotNetNuke.Services.Url.FriendlyUrl.DNNFriendlyUrlProvider, DotNetNuke.HttpModules" includePageName="true" regexMatch="[^a-zA-Z0-9 _-]" urlFormat="advanced" />
</providers>
</friendlyUrl>

See: http://www.dnnsoftware.c...-advanced-url-management

This fixed the store links.

However, as soon as I reinstalled the OpenURL_Rewriter module - I lost the product links again.

<friendlyUrl defaultProvider="OpenFriendlyUrl">
<providers>
<clear />
<add name="DNNFriendlyUrl" type="DotNetNuke.Services.Url.FriendlyUrl.DNNFriendlyUrlProvider, DotNetNuke.HttpModules" includePageName="true" regexMatch="[^a-zA-Z0-9 _-]" urlFormat="advanced" />
<add name="OpenFriendlyUrl" type="Satrabel.Services.Url.FriendlyUrl.OpenFriendlyUrlProvider, Satrabel.OpenUrlRewriter" includePageName="true" regexMatch="[^a-zA-Z0-9 _-]" urlFormat="advanced" fileExtension="" />
</providers>
</friendlyUrl>

Edited by user Friday, August 4, 2017 5:44:41 PM(UTC)  | Reason: Not specified

leedavi  
#5 Posted : Saturday, August 5, 2017 9:08:15 AM(UTC)
leedavi

Rank: Administration

Groups: Registered, Administrators
Joined: 11/6/2016(UTC)
Posts: 325
United Kingdom
Location: France

Was thanked: 28 time(s) in 28 post(s)
The url is all cached, go into the URL rewriter and check you get your products listed, if not clear open url rewriter cache rerun the provider.

We did have some problme gettig it ionto sync but it sould be all working OK now. It's currently running live wothout error. http://www.deotextil.com...-shirts/jn663-pull-femme
Daniel Comp  
#6 Posted : Saturday, August 5, 2017 7:13:34 PM(UTC)
Daniel Comp

Rank: Advanced Member

Groups: Registered
Joined: 12/20/2016(UTC)
Posts: 56
United States
Location: Hood River

It turns out that the URLRewriter either saves prior installation settings, or it sets the ENHANCED 404 check box ON during installation.

Un-checking the ENHANCED URL setting restores the Product Link Paths!

URLRewriter ENHANCED 404 setting

Issue resolved.

Back to your recreation and family!!
leedavi  
#7 Posted : Sunday, August 6, 2017 5:59:25 AM(UTC)
leedavi

Rank: Administration

Groups: Registered, Administrators
Joined: 11/6/2016(UTC)
Posts: 325
United Kingdom
Location: France

Was thanked: 28 time(s) in 28 post(s)
OK, thx for the feedback. I assume that 404 option only deals with DNN links. Strange I would have expect the full cache to be checked. I'll point Sacha (Creator of Open Url Rewriter) at this and see what he says.
Daniel Comp  
#8 Posted : Sunday, August 6, 2017 6:39:26 AM(UTC)
Daniel Comp

Rank: Advanced Member

Groups: Registered
Joined: 12/20/2016(UTC)
Posts: 56
United States
Location: Hood River

Here's a short exchange on this a year ago or so...
https://github.com/sacha...OpenUrlRewriter/issues/1


Thanks for your assistance.
leedavi  
#9 Posted : Sunday, August 6, 2017 6:50:42 AM(UTC)
leedavi

Rank: Administration

Groups: Registered, Administrators
Joined: 11/6/2016(UTC)
Posts: 325
United Kingdom
Location: France

Was thanked: 28 time(s) in 28 post(s)
OK, the Guy from deotextil sponsored the work, with me and Sacha working togeather to develop it. Wish I'd know at the time your were willing to help sponsor. I'm fairly sure we did this work at a loss. :-)
sachatrauawaen  
#10 Posted : Monday, August 7, 2017 9:55:10 AM(UTC)
sachatrauawaen

Rank: Newbie

Groups: Registered
Joined: 8/7/2017(UTC)
Posts: 1
Belgium
Location: Louvain-la-Neuve

Hi,

Yes, OUR dont delete prior instalation settings.

ENHANCED 404 is andvanced stuff.

Here more information about it :
https://openurlrewriter....rringTitle=Documentation

Regards,
Sacha

Expertmedia  
#11 Posted : Tuesday, July 16, 2019 10:14:54 AM(UTC)
Expertmedia

Rank: Newbie

Groups: Registered
Joined: 7/16/2019(UTC)
Posts: 1
Man
Belgium
Location: Gent

Hello Daniel
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2019, Yet Another Forum.NET
This page was generated in 0.105 seconds.