logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

2 Pages12>
Options
Go to last post Go to first unread
Vikingo  
#1 Posted : Saturday, September 22, 2018 3:03:47 AM(UTC)
Vikingo

Rank: Member

Groups: Registered
Joined: 9/21/2018(UTC)
Posts: 13
United States
Location: Texas

I used NBStore a lot in old days without problems, but I cannot figure out here, what I do wrong even after 3 days fight :-)
I have downloaded 3 different versions with same issues, so it's me that do something wrong, apparently! (I'm now in v4.0.3.)

Minicart has no button: "add to basket", or something like that, and clicking on it does nothing?

Clicking on the item name goes just to a 404 page. I have made an independent detail page, and configured it in admin.
(Shouldn't it also work just to click on the image?)

Everything else seems to be working...

I'm giving up now, unless somebody can help me, please.
leedavi  
#2 Posted : Saturday, September 22, 2018 3:06:58 AM(UTC)
leedavi

Rank: Administration

Groups: Registered, Administrators
Joined: 11/6/2016(UTC)
Posts: 322
United Kingdom
Location: France

Was thanked: 28 time(s) in 28 post(s)
This sounds like the settings in the Store setting are not setup?

Have a look here: https://doc.openstore-ecommerce.com/#11470
Vikingo  
#3 Posted : Saturday, September 22, 2018 3:42:16 AM(UTC)
Vikingo

Rank: Member

Groups: Registered
Joined: 9/21/2018(UTC)
Posts: 13
United States
Location: Texas

Hi leedavi

This is the thing - normally I can find out of these things!

I have made the back office and made sure everything is saved.

I have gone through again and again and cannot figure out what's wrong?
Vikingo  
#4 Posted : Saturday, September 22, 2018 3:44:42 AM(UTC)
Vikingo

Rank: Member

Groups: Registered
Joined: 9/21/2018(UTC)
Posts: 13
United States
Location: Texas

leedavi  
#5 Posted : Saturday, September 22, 2018 3:48:28 AM(UTC)
leedavi

Rank: Administration

Groups: Registered, Administrators
Joined: 11/6/2016(UTC)
Posts: 322
United Kingdom
Location: France

Was thanked: 28 time(s) in 28 post(s)
Yes, this looks like it's simply redirectig back to the same page?

In the store setting make sure you have the cart page selected for the "Redirect To (Cart)" option.

leedavi  
#6 Posted : Saturday, September 22, 2018 3:48:52 AM(UTC)
leedavi

Rank: Administration

Groups: Registered, Administrators
Joined: 11/6/2016(UTC)
Posts: 322
United Kingdom
Location: France

Was thanked: 28 time(s) in 28 post(s)
PM me a login if you want and I'll check it out.
leedavi  
#7 Posted : Saturday, September 22, 2018 4:13:06 AM(UTC)
leedavi

Rank: Administration

Groups: Registered, Administrators
Joined: 11/6/2016(UTC)
Posts: 322
United Kingdom
Location: France

Was thanked: 28 time(s) in 28 post(s)
OK, all store settings seemed OK.

But, did see an error with the fullCart module going to the checkout.

the url was: http://...../Default.aspx?tabid=140?cartstep=2

obviously it should be : http://...../Default.aspx?tabid=140&cartstep=2

This might be an issue with the store setting selection.

However, there is a setting in the fullcart module to selected the redirect page, when I set that correctly it created the correct url.

I'll mark this as an issue on OpenStore.
Vikingo  
#8 Posted : Saturday, September 22, 2018 4:19:50 AM(UTC)
Vikingo

Rank: Member

Groups: Registered
Joined: 9/21/2018(UTC)
Posts: 13
United States
Location: Texas

But what about the 404 page when you click on the items?

Did you solve that?
leedavi  
#9 Posted : Saturday, September 22, 2018 4:20:39 AM(UTC)
leedavi

Rank: Administration

Groups: Registered, Administrators
Joined: 11/6/2016(UTC)
Posts: 322
United Kingdom
Location: France

Was thanked: 28 time(s) in 28 post(s)
didn't see that, I'll check
Vikingo  
#10 Posted : Saturday, September 22, 2018 4:23:56 AM(UTC)
Vikingo

Rank: Member

Groups: Registered
Joined: 9/21/2018(UTC)
Posts: 13
United States
Location: Texas

I see that I cannot come further in the checkout now?

I actually followed this in the instruction...

"On the Basket page, the OS_FullCart module settings will also need changing to redirect to the checkout. The idea of having a FullCart Page and a Checkout page is so that on webistes which need a login the DNN security can be activated to force a login before the client fills out the address on the checkout. (i.e. the Fullcart page has public access the Checkout page has only registered User access.)"

Thats why I redirected and this was actually working...
Vikingo  
#11 Posted : Saturday, September 22, 2018 4:39:36 AM(UTC)
Vikingo

Rank: Member

Groups: Registered
Joined: 9/21/2018(UTC)
Posts: 13
United States
Location: Texas

Yes, the minicart is working perfect now!! Thanks!

But the detail page - what's going on with that. I don't see anything wrong in the settings?
leedavi  
#12 Posted : Saturday, September 22, 2018 4:41:28 AM(UTC)
leedavi

Rank: Administration

Groups: Registered, Administrators
Joined: 11/6/2016(UTC)
Posts: 322
United Kingdom
Location: France

Was thanked: 28 time(s) in 28 post(s)
I think this is a problem with DNN. Has the site been upgraded from an old version?

There is something strange about the urls on this site.

http://........./Detail/tabid/138/catid/76/eid/120/language/en-US/dog-dove

does NOT work

http://......./Detail/tabid/138/catid/76/eid/120/language/en-US/default.aspx

This does work??


I would have expected both to work, but also I would not have expected the "tabid" param to appear in the url, the page name is there and usually deals with the tabid param.

If you can;t fix the url problem then one work around to could be to alter the product list template and hardcode the url, using razor to display the dynamic content, like product id, in the url.



Vikingo  
#13 Posted : Saturday, September 22, 2018 4:47:07 AM(UTC)
Vikingo

Rank: Member

Groups: Registered
Joined: 9/21/2018(UTC)
Posts: 13
United States
Location: Texas

Yes, I just upgradet from 7.0.4. to 8.0.4 in order to get Open Store.

The work around you explain I actually don't understand how to do...
leedavi  
#14 Posted : Saturday, September 22, 2018 5:00:45 AM(UTC)
leedavi

Rank: Administration

Groups: Registered, Administrators
Joined: 11/6/2016(UTC)
Posts: 322
United Kingdom
Location: France

Was thanked: 28 time(s) in 28 post(s)
1. move "\DesktopModules\NBright\NBrightBuy\Themes\ClassicAjax\Default\ProductDisplayListBody.cshtml" template to portal level "\Portal\0\Themes\ClassicAjax\Default\ProductDisplayListBody.cshtml" (this is so it's not overwritten on upgrade.) https://doc.openstore-ecommerce.com/#11506

2. Edit the portal level file. Replace the razor token @EntryUrl(info,Model) with something like this: "http://......./Detail/tabid/138/catid/@(product.GetDefaultCategory())/eid/@(info.ItemID)/language/en-US/default.aspx"

You might have to play around with it a little, but I think it should work. OpenStore has never been developed/tested against DNN7, I presume some settings on url have kept the old method and hence is causing an issue.
Vikingo  
#15 Posted : Saturday, September 22, 2018 5:10:42 AM(UTC)
Vikingo

Rank: Member

Groups: Registered
Joined: 9/21/2018(UTC)
Posts: 13
United States
Location: Texas

I never tried OpenStore on 7.0.4.
I upgraded DNN to 8 because I wanted the OpenStore :-)

I will try, if I can find out of your explanation - I hope so!
Years ago I used NBStore a lot and was very happy for it.

But thanks a lot for your support leedavi, I really appreciated it!

Best Regards,
Per
leedavi  
#16 Posted : Saturday, September 22, 2018 5:16:15 AM(UTC)
leedavi

Rank: Administration

Groups: Registered, Administrators
Joined: 11/6/2016(UTC)
Posts: 322
United Kingdom
Location: France

Was thanked: 28 time(s) in 28 post(s)
Yes, I think it's DNN trying to be clever and keep outdated setting so urls don't change and SEO is kept. But I'm unsure.

One option could be to export your site to a DNN template, setup a new DNN8 version from the start using your exported DNN template. This might give you a clean install with urls working as expected, but the import might also keep the urls working the same.
Vikingo  
#17 Posted : Saturday, September 22, 2018 5:22:02 AM(UTC)
Vikingo

Rank: Member

Groups: Registered
Joined: 9/21/2018(UTC)
Posts: 13
United States
Location: Texas

If I can find out of your other work around, I think this is an easier solution, but I will think about what to do.

Thanks again, leedavi, you are giving a great support!

Best Regards,
Per
Vikingo  
#18 Posted : Tuesday, October 2, 2018 5:03:08 PM(UTC)
Vikingo

Rank: Member

Groups: Registered
Joined: 9/21/2018(UTC)
Posts: 13
United States
Location: Texas

I couldn't solve the problem with the wrong link, so I decided to rollback to the dnn 7.0.4. I had before and install NB Store which I have used a lot before.
Everything is working perfect, except for one thing that drive me crazy:

In the detail view it's showing a button: "Choose file" - and I have been looking all over for days to get reach of that, but I cannot figure it out.

I get told that I have to go here: Admin>Settings>Folders> "Activate Client File Upload Option"
- but I'm unable to find this?!

Are you kind to help me?
Vikingo  
#19 Posted : Tuesday, October 2, 2018 8:00:45 PM(UTC)
Vikingo

Rank: Member

Groups: Registered
Joined: 9/21/2018(UTC)
Posts: 13
United States
Location: Texas

OK, I have continue investigated and googled the problem, and I found a post from June 2013 with exactly the same problem!
Guess who was asking of help: ME

Here the answer:
Hi Per,

It is the Skin compatibility issue documented on this page:
https://nbstore.codeplex...le=System%20requirements

Regards
Rob

The problem is, that everytime you follow an old link, it will only advertise with the new OpenStore (so, no answer) except that it's a knowing problem.

I have given up and solved the problem in this way:
I deleted this:

<div class="FileUpload Row">
<div class="Label">Upload</div>
<div class="Value">[TAG:UPLOAD:<prop CssClass="NormalTextBox" />]
[TAG:OPTIONVALREGX:<prop ErrorMessage="File must be a pdf,doc or txt." Text="*" ControlToValidate="fuupload" ValidationExpression="^.+\.(doc|txt|pdf|Doc|Txt|Pdf|DOC|TXT|PDF)$" />]

</div>

...between file upload begin and file upload end.

This is of course not the right way to do it, but it has solved the problem temporary.

If anyone know how to solve this issue in the right way, I would be happy, because the folder in Admin that Leedavi suggest, I cannot find at all.
robax  
#20 Posted : Wednesday, October 3, 2018 5:26:41 AM(UTC)
robax

Rank: Newbie

Groups: Registered
Joined: 10/3/2018(UTC)
Posts: 3
New Zealand

Originally Posted by: Vikingo Go to Quoted Post
OK, I have continue investigated and googled the problem, and I found a post from June 2013 with exactly the same problem!
Guess who was asking of help: ME

Here the answer:
Hi Per,

It is the Skin compatibility issue documented on this page:
https://nbstore.codeplex...le=System%20requirements

Regards
Rob

The problem is, that everytime you follow an old link, it will only advertise with the new OpenStore (so, no answer) except that it's a knowing problem.




The Codeplex page offers a download of the NB Store content. The relevant answer in there was this:

Skin compatibility
Some recent DNN skins have an incompatibility with the Store. The issue shows itself as a Buy button and quantity field being visible in the list view, and also similar weirdness in the details view, such as a file upload field that won't go away. If your store is looking confused, examine your skin's ASCX files and remove any visible="False" attributes from all content panes.

Regards
ROb
Users browsing this topic
2 Pages12>
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2019, Yet Another Forum.NET
This page was generated in 0.144 seconds.